Quick answers
- Is CVE-2026-120246 exploited in the wild?
- No. Junglewise Threat Intelligence has no report of CVE-2026-120246 being exploited in the wild.
- How severe is CVE-2026-120246?
- Medium severity, with a CVSS score of 5.5, published 1 November 2026.
- Which products and versions are affected?
- Ffmpeg 4.4 through 9.0.2.
- Is there a fix for CVE-2026-120246?
- Yes: fixed in FFmpeg 9.1. Junglewise finds every place you run it, drafts the upgrade and applies it once you approve.
- How is CVE-2026-120246 attacked?
- It is attacked with local access, in a software library.
- Am I affected by CVE-2026-120246?
- Check whether you run Ffmpeg at an affected version. Junglewise does that check for you around the clock: connect your code, cloud and domains, and it matches new vulnerabilities like this one against what you actually run and tells you when one reaches you.
How to fix
- Fixed in: FFmpeg 9.1
Technical details
The vulnerability exists in the HAM6 and HAM8 pixel decoders (cdxl_decode_ham6/ham8 functions) within the CDXL decoder component. When processing type-0 CDXL files with partially-filled palette entries, the decoder reads from uninitialized palette indices (10–15 for HAM6, 42–63 for HAM8), leaking stack bytes into BGR24 output pixels. The vulnerability requires processing a crafted CDXL input file but no user interaction beyond initiating decode. A fix validates palette indices before reading, rejecting frames that reference uninitialized entries.
Affected products
- FFmpeg FFmpeg 4.4 through 9.0.2
Timeline
- 2026-11-01: disclosed
- 2026-10-05: patched: Fix merged in commit 7266f70aa6 to master, scheduled for 9.1 release