Quick answers
- Is CVE-2026-115946 exploited in the wild?
- No. Junglewise Threat Intelligence has no report of CVE-2026-115946 being exploited in the wild.
- How severe is CVE-2026-115946?
- Informational severity, published 1 November 2026.
- Which products and versions are affected?
- Perl XS::libbrotli before 1.2.1.0.
- Is there a fix for CVE-2026-115946?
- Yes: fixed in XS::libbrotli 1.2.1.0. Junglewise finds every place you run it, drafts the upgrade and applies it once you approve.
- How is CVE-2026-115946 attacked?
- It is attacked over the network, in a software library.
- Am I affected by CVE-2026-115946?
- Check whether you run Perl XS::libbrotli at an affected version. Junglewise does that check for you around the clock: connect your code, cloud and domains, and it matches new vulnerabilities like this one against what you actually run and tells you when one reaches you.
How to fix
- Fixed in: XS::libbrotli 1.2.1.0
Technical details
XS::libbrotli bundles brotli 1.0.7 or 1.1.0 (instead of using the system library), which contains an out-of-bounds write vulnerability in the decoder (CVE-2026-111497). Dependent Perl modules that decompress untrusted brotli streams are vulnerable; an attacker can craft a malicious brotli stream to trigger corruption of decoder state, memory disclosure, denial of service, or remote code execution. Upgrading the system brotli does not mitigate this, since the vulnerable copy is statically linked at build time.
Affected products
- Perl XS::libbrotli before 1.2.1.0
Timeline
- 2026-11-01: disclosed